Why I run the report, it shows The request failed with HTTP status 400: Bad Request. thank you very

The detailed information is as follows:

Error Description:

The request failed with HTTP status 400: Bad Request.

Error Details:

The request failed with HTTP status 400: Bad Request.

Full Stack:

[WebException: The request failed with HTTP status 400: Bad Request.]
  at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
  at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
  at Microsoft.Crm.ReportingServices2005.ReportingService2005.ListExtensions(ExtensionTypeEnum ExtensionType)
  at Microsoft.Crm.Reporting.ReportServer.IsDataExtensionInstalled(String extensionName)

[CrmReportingException: The request failed with HTTP status 400: Bad Request.]
  at Microsoft.Crm.Reporting.ReportServer.IsDataExtensionInstalled(String extensionName)
  at Microsoft.Crm.Reporting.ReportServer.get_IsDataConnectorInstalled()
  at Microsoft.Crm.Web.Reporting.CrmReportServerCredentials.get_ImpersonationUser()
  at Microsoft.Reporting.WebForms.ServerReport.OnCredentialsChanged(IReportServerCredentials credentials)
  at Microsoft.Reporting.WebForms.ServerReport.set_ReportServerCredentials(IReportServerCredentials value)
  at Microsoft.Reporting.WebForms.ReportViewer.ApplyConnectionToServerReport(IReportServerConnection connection, ServerReport serverReport)
  at Microsoft.Reporting.WebForms.ReportViewer.CreateServerReport()
  at Microsoft.Reporting.WebForms.ReportViewer.CreateReportHierarchy()
  at Microsoft.Reporting.WebForms.ReportViewer..ctor()
  at ASP.ch_ina_crmreports_rsviewer_reportviewer_aspx.__BuildControlreportViewer()
  at ASP.ch_ina_crmreports_rsviewer_reportviewer_aspx.__BuildControlform1()
  at ASP.ch_ina_crmreports_rsviewer_reportviewer_aspx.__BuildControlTree(ch_ina_crmreports_rsviewer_reportviewer_aspx __ctrl)
  at ASP.ch_ina_crmreports_rsviewer_reportviewer_aspx.FrameworkInitialize()
  at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
  at System.Web.UI.Page.ProcessRequest()
  at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
  at System.Web.UI.Page.ProcessRequest(HttpContext context)
  at ASP.ch_ina_crmreports_rsviewer_reportviewer_aspx.ProcessRequest(HttpContext context)
  at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
  at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Other Message:
Error Number:

0x80048300

Source File:

Not available

Line Number:

Not available

errorHeader Why I run the report, it shows The request failed with HTTP status 400: Bad Request. thank you very
Date: 07-15-2010

Time: 13:29:00

Server: crm.ch-ina.com

Request URL:

http://crm.ch-ina.com/CH-ina/CRMReports/rsviewer/reportviewer.aspx

 

 

 

 

Can you run  the report  directly from the Report Server?  Is this a default or custom report?  If custom, did you create it using the Report Wizard or Visual Studio?/

Hi,Please check SQL Reporting Error Log for more details of the error.Log on to SQL Server, go to installation folder of SQL Server Reporting Services. Open the latest log file and see the error description.Hope this will help.