Unable to remove search service application

I have a SSA that unfortunately lost its crawl database.  It’s not a critical DB so I then tried to remove it via Central Admin.  The remove dialog appeared and I checked “remove data”.  The dialog sat for at least half an hour and at that
point I just killed it.  I then tried to remove using the Powershell cmdlet Remove-SPEnterpriseSearchServiceApplication, which basically behaves the same way.  I say “Yes”, but the command never returns.  

Is there another way to forcibly remove an application?

I haven’t seen a force there, but one might exist. Have you tried an iisreset prior to trying to delete it? You could also stop the SharePoint Server Search 14 service, or even provision another Search service  and try moving your web apps over to the new

Solution:Stsadm -o deleteconfigurationobject -id “id retrieved from search  application link” (if you hoover over it you’ll see it)So you have to fill in the quotes the GUID from the search application. If it’s 97s2fgd9-453k-3423-f334-8r78jd3bv2t6 you have to give:Stsadm -o deleteconfigurationobject -id 97s2fgd9-453k-3423-f334-8r78jd3bv2t6Reference to this post:

Alpesh,That did the trick.  Thanks.  Although I got the id from Get-SPEnterpriseSearchServiceApplication 🙂  Didn’t follow you on the hovertrick.  Regardless, it’s gone 🙂