Strange problem with References ……..?

we are using Visual studio 2010 and silverlight 4

our project is successfully build in my local machine…..

but when I run the build script to deploy to Dev Environment its giving me the following error…..

objDebugViewsDocumentViewerView.g.cs (41): The type or namespace name ‘C1PdfViewer’ could not be found (are you missing a using directive or an assembly reference?)

Then I checked the version of C1.Silverlight.PdfViewer.dll.  the version is 4.0.20103.86, I found aonther dll with latest version ( 4.0.20111.124) in my machine.  I just deleted the old one and re added the new version.

Now the build is not giving the same error, but now its giving the different error

c:BuildsxxxxxxxxxxxxxxxxxViewsDocumentViewerView.xaml (1): Could not load file or assembly ‘C1.Silverlight’, Version=4.0.2011.124, Culture=neutral, PublicKeyToken=2aa4ec5578d6c3ce’ or one of its dependencies.  the system cannot find the
file specified.

[ In my machine I dont have any C1.Silverlight.dll with version = 4.0.2011.124]

Moreover when I change the C1.silverlight.Pdfviewer.dll to the version = 4.0.2011.124 from 4.0.20103.86, its not build even in my local machine (but its not giving any error about this dll when I run build script)…..

 

really I appreciate alot, if any one can give me suggestions as I dont have any idea about this kind of error…….

Hope you guys understand my question, otherwise please ask me again?

Thanks for your time

sxct.

 

Hi sxct, Thanks for your post. In order to resolve this issue, I want to confirm some information with you:1       

Hi sxct, I marked the reply as answer, if you have any concern with it, please feel free to unmark it.