SQL Server 2005 fails to start after install on Server 2008 R2 SP1 64-bit

New install of Server 2008 R2 64-bit upgraded to SP1.

I have SQL Server 2005, no matter how I install it, it fails to start the main SQL Service giving me the error:

“The SQL Server service failed to start. For more information, see the SQL Server Books Online topics, “How to: View SQL Server 2005 Setup Log Files” and “Starting SQL Server Manually.””

It then rolls back just that portion of the install and completes the install. I thought the following article might be the ticket, but no matter which SQL Server 2005 SP I try this with or which method they describe (reducing processor count, etc), I get
the same error: http://support.microsoft.com/kb/954835/en-us

Is it SP1 on Server 2008 R2 that is the problem? I have found various articles online speaking of pretty much the same issue, but these are posted before SP1 and people seem to be able to get things working.

Any thoughts?

Can you check the SQL Server error logs, and the application event logs, if you can find more details, and information about this issue.. /

Below are some Application Event Logs to get started with. I verified that the above link (http://support.microsoft.com/kb/954835/en-us) has an error that appears in the SQLSetup Log file that matches

Hi,SQL Server 2008 R2 SP1 is still not released. What is the version you are trying to install? Can you provide the KB number from where you downloaded the installation package?-Manu