.NET Framework 4 Installation error – Generic Trust Failure

I tried to install .NET Framework 4 on Windows Server 2003, but got this error message “Generic trust failure”.

Part of the log:

Action: Downloading and/or Verifying Items

C:e005b9f00558a52d0cWindows6.0-KB956250-v6001-x86.msu: Verifying signature for Windows6.0-KB956250-v6001-x86.msu

C:e005b9f00558a52d0cWindows6.0-KB956250-v6001-x86.msu Signature verified successfully for Windows6.0-KB956250-v6001-x86.msu

C:e005b9f00558a52d0cWindows6.1-KB958488-v6001-x86.msu: Verifying signature for Windows6.1-KB958488-v6001-x86.msu

C:e005b9f00558a52d0cWindows6.1-KB958488-v6001-x86.msu Signature verified successfully for Windows6.1-KB958488-v6001-x86.msu

C:e005b9f00558a52d0cnetfx_Core.mzz: Verifying signature for netfx_Core.mzz

C:e005b9f00558a52d0cnetfx_Core.mzz Signature verified successfully for netfx_Core.mzz

C:e005b9f00558a52d0cnetfx_Core_x86.msi: Verifying signature for netfx_Core_x86.msi

Possible transient lock. WinVerifyTrust failed with error: 2148204800

Possible transient lock. WinVerifyTrust failed with error: 2148204800

C:e005b9f00558a52d0cnetfx_Core_x86.msi – Signature verification for file netfx_Core_x86.msi (C:e005b9f00558a52d0cnetfx_Core_x86.msi) failed with error 0x800b0100 (No signature was present in the subject.)

C:e005b9f00558a52d0cnetfx_Core_x86.msi Signature could not be verified for netfx_Core_x86.msi

No FileHash provided. Cannot perform FileHash verification for netfx_Core_x86.msi

File netfx_Core_x86.msi (C:e005b9f00558a52d0cnetfx_Core_x86.msi), failed authentication. (Error = -2146762496). It is recommended that you delete this file and retry setup again.

Failed to verify and authenticate the file -C:e005b9f00558a52d0cnetfx_Core_x86.msi

Please delete the file, C:e005b9f00558a52d0cnetfx_Core_x86.msi and run the package again

Action complete

Action: Performing actions on all Items

Action: ServiceControl – Stop clr_optimization_v2.0.50727_32

ServiceControl operation succeeded!

Action complete

Final Result: Installation failed with error code: (0x800B010B), “Generic trust failure. ” (Elapsed time: 0 00:00:26).

 

Please. help to solve problem!!

 

Could you collect your .Netfx4 setup logs following the instructions at http://blogs.msdn.com/heaths/pages/collect.aspx and post them somewhere we can access? (you can use skydrive.live.com to post the logs). How did you run the setup? I mean, did you run the redist directly or extract it somewhere and then run setup.exe?There are two possible causes for this failure:An aniti-virus application running on the system has locked the file for virus scan.  ORthe file has been corrupted during or after the extraction. I think, it is a good idea to retry few times to see if it works or not.Regards,Muhammad Ghaznawi/

Hi!I tried a lot of time! And I tried to install  it on 3 computers with Windows Server 2003! Earlier I tried to install .NET 4 RC, but there was this error.I run en_.net_framework_4_full_x86_x64_508940.exe which I’ve downloaded from MSDN.Soon I try to collect setup logs and post them.

Hello,Is your issue resolved? If not, could you please post the log or sent it to me (v-jinfan{at}microsoft.com) for better troubleshooting?In addition, I have came across similar issue which is resolved by installing with a local account with Administrator rights. You can have a try.