Could not start the DSS Node – works if I run VPL as Administrator

I am running into the problem on one machine that I cannot start the DSS node when I run from VPL.  This works on my other machine.  On the machine where it does not work, I’ve verified that it does not seem to be a port issue.  If I run VPL as Administrator (i.e. right click the start menu item and select “Run as Administrator”) it works.  The problem is that the particular service I’m trying to work with has to run as the local user, not administrator.

 

Any ideas on what could be configured wrong on the machine where this is not working?

 

DSS nodes need to listen on ports. This is a privileged function, so Admin accounts will work  but normal user  accounts might not depending on the security settings on your PC. To get around this problem  there is a utility called httpreserve that allows you to reserve a particular port  for a specified user. Please look in the RDS documentation and search for httpreserve.Trevor 

Thanks, Trevor – I should have said in my original post that I did try the httpreserve utility:Note the environment_USERDOMAIN=MikeKellyUSERNAME=Mike KellyUSERPROFILE=C:UsersMike KellyVISUALSVN_SERVER=C:Program FilesVisualSVN ServerVS100COMNTOOLS=C:Program FilesMicrosoft Visual Studio 10.0Common7ToolsVS90COMNTOOLS=C:Program FilesMicrosoft Visual Studio 9.0Common7Toolswindir=C:WindowsC:UsersMIKEKE~1MICROS~2projectsSerialPort>httpreserve /p:50000 /u:”Mike Kelly” /d:MikeKellyUnable to reserve port  50000.C:UsersMIKEKE~1MICROS~2projectsSerialPort>httpreserve /p:50000 /u:”Mike Kelly”Unable to reserve port 50000.C:UsersMIKEKE~1MICROS~2projectsSerialPort>So as other topics on here note, there are two possible cases: something else is listening on the port, or there is a permissions issue.  I think I’ve eliminated the “something else is listening on the port” possibility by running  as Admin and seeing it work.  Here also is the output of netstat -a -t and 50000 is not listed:Active Connections  Proto  Local Address          Foreign Address        State           Offload State  TCP    0.0.0.0:80             MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:135            MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:445            MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:554            MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:641            MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:2099           MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:2869           MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:3389           MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:3390           MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:5357           MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:8019           MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:8443           MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:10243          MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:49152          MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:49153          MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:49154          MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:49155          MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:49158          MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:49159          MikeKelly:0            LISTENING       InHost        TCP    0.0.0.0:49298          MikeKelly:0            LISTENING       InHost        TCP    127.0.0.1:49298        MikeKelly:49305        ESTABLISHED     InHost        TCP    127.0.0.1:49298        MikeKelly:58603        ESTABLISHED     InHost        TCP    127.0.0.1:49298        MikeKelly:59760        ESTABLISHED     InHost        TCP    127.0.0.1:49305        MikeKelly:49298        ESTABLISHED     InHost        TCP    127.0.0.1:58603        MikeKelly:49298        ESTABLISHED     InHost        TCP    127.0.0.1:59760        MikeKelly:49298        ESTABLISHED     InHost        TCP    192.168.2.51:139       MikeKelly:0            LISTENING       InHost        TCP    192.168.2.51:2099      MikeKelly:49304        ESTABLISHED     InHost     Both machines are Windows 7.  Both have a bunch of additional stuff installed – one thing that I thought could be the culprit that is installed onthe machine  that’s not working  but isn’t on the machine that is is Visual SVN Server – the Subversion source control server, which is connected to over http.  But it is listening on http://mikekelly:8443/svnI am not 100% blocked by this because as I say, I have one machine that is working.  I suppose I could do a complete uninstall and reinstall of RDS on the machine that isn’t working and see if that helps.  Are there any other ideas?  Everything else in this forum on this problem  has focused on the “port in use” aspect, but I think I really have encountered some sort of wierd permission configuration issue.Thanks.

I’m having the same problem  an im the administrator  and i just can’t run  the dss  node and i have tried the same things. if you figured out how to fix it please let me know.