2008 Reporting Services promting for a username and password prompt

I installed 3 2008 R2 64 bit servers.  1 has IIS only, 1 has iis and sql and 1 has sql only.

These are all vanilla installs except they are all in the domain, I do not have this issue on the qa boxes I built the exact same way but are not in the domain.

Webserver has IIS, web.config points to
http://ipaddress/reportserver
 has impersonate user servernameuser and password

SQL server is running sql standard 2008 SP1.  It has the databases and users set up correctly as the qa did.

Report server has IIS and sql 2008 sp1.  I created a local user account and tried a domain account as well but still get the security prompt after logging into the report server.  If I enter the username and password for the reportserver database
it opens the reports and lets me work on them.  But no matter what I’ve tried I get the username and password prompt for the report server before the reports page will open.  I’m not sure how much information you need so please let me know, thanks.

Hi,